Database deadlock
Incident Report for TaskMaster Pro
Resolved
All services functional and stable.
Posted Oct 12, 2017 - 12:44 CDT
Monitoring
Service restored. Monitoring for anomalies.
Posted Oct 12, 2017 - 12:17 CDT
Update
Sync taking longer than expected, but almost finished. Should be back up soon. NO DATA IS LOST or was ever in danger of being lost.
Posted Oct 12, 2017 - 11:38 CDT
Update
Alternate location will soon be up and running. Waiting for initial sync to finish before switching production.
Posted Oct 12, 2017 - 11:00 CDT
Update
Database crash recovery taking longer than expected. Exploring alternative options.
Posted Oct 12, 2017 - 10:50 CDT
Identified
The cause has been identified and a fix is underway. TaskMaster Pro has been put into maintenance mode.
Posted Oct 12, 2017 - 10:35 CDT
Investigating
We are investigating the cause and resolution of a database deadlock between our geographic locations. Will provide additional details as they become available.
Posted Oct 12, 2017 - 10:31 CDT